EurekaLog 6의 하위 호환성 문제

No Comments

 저번에 EurekaLog 6 버전을 AcroEdit에 적용하려다 프로그램이 동작하지 않는 문제로 인해 다시 EurekaLog 5로 돌아간 적이 있습니다. AcroEdit 뿐만 아니고 개발하고 있는 대부분의 어플리테이션에서 동일한 문제가 발생하여  2주 동안 문제의 원인을 추적한 결과 겨우 이유를 알았습니다. AcroEdit에서 사용하는 DLL은 EurekaLog 5로 컴파일되고 AcroEdit는 EurekaLog 6로 컴파일한 것이 문제였습니다.
 EurekaLog 6 버전에서 하위 버전과 충돌이 일어나 해당 DLL을 로딩하지 못해서 발생한 것입니다.

이런….

추가 (2007.04.19)
6.0.2 버전에서 이 문제가 해결되었습니다.

Leave a Reply